What’s Vulnerable › Vulnerabilities
CVE-2024-1053: Event Tickets and Registration <= 5.8.1 - Missing Authorization
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-02-22 · updated 2026-06-17
- Weakness: CWE-284
Description
The Event Tickets and Registration plugin for WordPress is vulnerable to unauthorized access of data due to a missing capability check on the 'email' action in all versions up to, and including, 5.8.1. This makes it possible for authenticated attackers, with contributor-level access and above, to email the attendees list to themselves.
Affected products
- stellarwp Event Tickets and Registration: before 5.8.2 — fixed in 5.8.2
How to fix
Upgrade to a fixed version: stellarwp Event Tickets and Registration 5.8.2. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3038150/event-tickets/tags/5.8.2/src/Tickets/Commerce/Reports/Attendees.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/a7839847-2637-4a0d-bfc1-5f80b8433e24?source=cve
- https://plugins.trac.wordpress.org/changeset/3038150/event-tickets/tags/5.8.2/src/Tickets/Commerce/Reports/Attendees.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/a7839847-2637-4a0d-bfc1-5f80b8433e24?source=cve
Get alerted when CVE-2024-1053 or the next vulnerability affects your stack