What’s Vulnerable › Vulnerabilities
CVE-2024-10533: WP Chat App <= 3.6.8 - Missing Authorization to Authenticated (Subscriber+) Filebird Plugin Installation
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-16 · updated 2026-06-17
- Weakness: CWE-862
Description
The WP Chat App plugin for WordPress is vulnerable to unauthorized plugin installation due to a missing capability check on the ajax_install_plugin() function in all versions up to, and including, 3.6.8. This makes it possible for authenticated attackers, with Subscriber-level access and above, to install the filebird plugin.
Affected products
- ninjateam WP Chat App: before 3.6.9 — fixed in 3.6.9
How to fix
Upgrade to a fixed version: ninjateam WP Chat App 3.6.9. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/wp-whatsapp/tags/3.6.7/includes/Cross.php#L206
- https://plugins.trac.wordpress.org/browser/wp-whatsapp/trunk/includes/Cross.php#L206
- https://plugins.trac.wordpress.org/changeset/3186930/wp-whatsapp/trunk/includes/Cross.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/26f73bfe-f41a-4045-9d72-21181a9a704f?source=cve
Get alerted when CVE-2024-10533 or the next vulnerability affects your stack