What’s Vulnerable › Vulnerabilities
CVE-2024-10554: WP-Advanced-Search < 3.3.9.3 - Admin+ Stored XSS
- Severity: low (CVSS 3.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-03-25 · updated 2026-06-17
- Weakness: CWE-79
Description
The WordPress WP-Advanced-Search WordPress plugin before 3.3.9.3 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
Affected products
- Mathieu Chartier WordPress WP-Advanced-Search: before 3.3.9.3 — fixed in 3.3.9.3
How to fix
Upgrade to a fixed version: Mathieu Chartier WordPress WP-Advanced-Search 3.3.9.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-10554 or the next vulnerability affects your stack