What’s Vulnerable › Vulnerabilities
CVE-2024-1056: Funnel Kit Funnel Builder PRO <= 3.4.5 Authenticated(Contributor+) Stored Cross-Site Scripting via allow_iframe_tag_in_post
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-29 · updated 2026-06-17
- Weakness: CWE-79
Description
The FunnelKit Funnel Builder Pro plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'allow_iframe_tag_in_post' function which uses the 'wp_kses_allowed_html' filter to globally allow script and iframe tags in posts in all versions up to, and including, 3.4.5. This makes it possible for authenticated attackers, with contributor access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- amans2k FunnelKit – Funnel Builder for WooCommerce Checkout: before 3.5.0 — fixed in 3.5.0
How to fix
Upgrade to a fixed version: amans2k FunnelKit – Funnel Builder for WooCommerce Checkout 3.5.0. Check the vendor advisory for mitigations.
References
- https://myaccount.funnelkit.com/changelog/changelog-funnel-builder-pro/?v=7516fd43adaa
- https://www.wordfence.com/threat-intel/vulnerabilities/id/2fbacaf2-0b3e-4d1e-adc3-c501a6c4c816?source=cve
Get alerted when CVE-2024-1056 or the next vulnerability affects your stack