What’s Vulnerable › Vulnerabilities
CVE-2024-10563: WooCommerce Cart Count Shortcode < 1.1.0 - Contributor+ XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-02-26 · updated 2026-06-17
- Weakness: CWE-79
Description
The WooCommerce Cart Count Shortcode WordPress plugin before 1.1.0 does not validate and escape some of its shortcode attributes before outputting them back in a page/post where the shortcode is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks.
Affected products
- WooCommerce Cart Count Shortcode: before 1.1.0 — fixed in 1.1.0
How to fix
Upgrade to a fixed version: WooCommerce Cart Count Shortcode 1.1.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-10563 or the next vulnerability affects your stack