What’s Vulnerable › Vulnerabilities
CVE-2024-1057: ShopLentor – WooCommerce Builder for Elementor & Gutenberg +10 Modules – All in One Solution (formerly WooLentor) <= 2.8.1 - Authenticated (Contributor+) Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-20 · updated 2026-06-17
- Weakness: CWE-79
Description
The ShopLentor – WooCommerce Builder for Elementor & Gutenberg +10 Modules – All in One Solution (formerly WooLentor) plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'wishsuite_button' shortcode in all versions up to, and including, 2.8.1 due to insufficient input sanitization and output escaping on user supplied attributes like 'button_class'. This makes it possible for authenticated attackers with contributor-level and above permissions to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- devitemsllc ShopLentor – All-in-One WooCommerce Growth & Store Enhancement Plugin: before 2.8.2 — fixed in 2.8.2
How to fix
Upgrade to a fixed version: devitemsllc ShopLentor – All-in-One WooCommerce Growth & Store Enhancement Plugin 2.8.2. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3044764/woolentor-addons/tags/2.8.2/includes/modules/wishlist/includes/templates/wishsuite-button-add.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/b6d8212d-7e72-487d-a4e8-0582fa72f602?source=cve
- https://plugins.trac.wordpress.org/changeset/3044764/woolentor-addons/tags/2.8.2/includes/modules/wishlist/includes/templates/wishsuite-button-add.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/b6d8212d-7e72-487d-a4e8-0582fa72f602?source=cve
Get alerted when CVE-2024-1057 or the next vulnerability affects your stack