What’s Vulnerable › Vulnerabilities
CVE-2024-10571: Chartify – WordPress Chart Plugin <= 2.9.5 - Unauthenticated Local File Inclusion via source
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-11-14 · updated 2026-06-17
- Weakness: CWE-98
Description
The Chartify – WordPress Chart Plugin plugin for WordPress is vulnerable to Local File Inclusion in all versions up to, and including, 2.9.5 via the 'source' parameter. This makes it possible for unauthenticated attackers to include and execute arbitrary files on the server, allowing the execution of any PHP code in those files. This can be used to bypass access controls, obtain sensitive data, or achieve code execution in cases where images and other “safe” file types can be uploaded and included.
Affected products
- Ays Pro Chartify: before 2.9.6 — fixed in 2.9.6
How to fix
Upgrade to a fixed version: Ays Pro Chartify 2.9.6. Check the vendor advisory for mitigations.
References
- https://abrahack.com/posts/chart-builder-lfi/
- https://plugins.trac.wordpress.org/browser/chart-builder/tags/2.9.6/admin/partials/charts/actions/chart-builder-charts-actions-options.php?rev=3184238
- https://www.wordfence.com/threat-intel/vulnerabilities/id/d4837258-c749-4194-926c-22b67e20c1fc?source=cve
Get alerted when CVE-2024-10571 or the next vulnerability affects your stack