What’s Vulnerable › Vulnerabilities
CVE-2024-10581: DirectoryPress Frontend <= 2.7.9 - Cross-Site Request Forgery to Listing Status Update
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-15 · updated 2026-06-17
- Weakness: CWE-352
Description
The DirectoryPress Frontend plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 2.7.9. This is due to missing or incorrect nonce validation on the dpfl_listingStatusChange() function. This makes it possible for unauthenticated attackers to update listing statuses via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
Affected products
- Designinvento DirectoryPress: before 2.8.0 — fixed in 2.8.0
How to fix
Upgrade to a fixed version: Designinvento DirectoryPress 2.8.0. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3239657%40directorypress-frontend&new=3239657%40directorypress-frontend&sfp_email=&sfph_mail=
- https://www.wordfence.com/threat-intel/vulnerabilities/id/36986585-7aaa-4c49-b426-fb9078fbb9ae?source=cve
Get alerted when CVE-2024-10581 or the next vulnerability affects your stack