What’s Vulnerable › Vulnerabilities
CVE-2024-10585: InfiniteWP Client <= 1.13.0 - Unauthenticated Limited Directory Traversal to Arbitrary .txt File Reading
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-08 · updated 2026-06-17
- Weakness: CWE-22
Description
The InfiniteWP Client plugin for WordPress is vulnerable to Path Traversal in all versions up to, and including, 1.13.0 via the 'historyID' parameter of the ~/debug-chart/index.php file. This makes it possible for unauthenticated attackers to read .txt files outside of the intended directory.
Affected products
- revmakx InfiniteWP Client: before 1.13.1 — fixed in 1.13.1
How to fix
Upgrade to a fixed version: revmakx InfiniteWP Client 1.13.1. Check the vendor advisory for mitigations.
References
- https://plugins.svn.wordpress.org/iwp-client/tags/1.13.0/debug-chart/index.php
- https://plugins.trac.wordpress.org/changeset/3202851/iwp-client/trunk/debug-chart/index.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/4d2518f6-3647-4bee-a98c-ce7f30375a62?source=cve
Get alerted when CVE-2024-10585 or the next vulnerability affects your stack