What’s Vulnerable › Vulnerabilities
CVE-2024-10593: WPForms – Easy Form Builder for WordPress <= 1.9.1.6 - Cross-Site Request Forgery (CSRF) to Plugin's Log Deletion
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-13 · updated 2026-06-17
- Weakness: CWE-352
Description
The WPForms – Easy Form Builder for WordPress – Contact Forms, Payment Forms, Surveys, & More plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 1.9.1.6. This is due to missing or incorrect nonce validation on the process_admin_ui function. This makes it possible for unauthenticated attackers to delete WPForm logs via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
Affected products
- smub WPForms – Easy Form Builder for WordPress – Contact Forms, Payment Forms, Surveys, & More: before 1.9.2.1 — fixed in 1.9.2.1
How to fix
Upgrade to a fixed version: smub WPForms – Easy Form Builder for WordPress – Contact Forms, Payment Forms, Surveys, & More 1.9.2.1. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/wpforms-lite/tags/1.9.1.6/src/Admin/Tools/Views/Logs.php#L269
- https://plugins.trac.wordpress.org/browser/wpforms-lite/tags/1.9.1.6/src/Logger/ListTable.php#L394
- https://www.wordfence.com/threat-intel/vulnerabilities/id/6d1ea80a-a1ce-4964-8dde-f3ed2df5537c?source=cve
Get alerted when CVE-2024-10593 or the next vulnerability affects your stack