What’s Vulnerable › Vulnerabilities
CVE-2024-10627: WooCommerce Support Ticket System <= 17.7 - Unauthenticated Arbitrary File Upload
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-09 · updated 2026-06-17
- Weakness: CWE-434
Description
The WooCommerce Support Ticket System plugin for WordPress is vulnerable to arbitrary file uploads due to missing file type validation in the ajax_manage_file_chunk_upload() function in all versions up to, and including, 17.7. This makes it possible for unauthenticated attackers to upload arbitrary files on the affected site's server which may make remote code execution possible.
Affected products
- vanquish WooCommerce Support Ticket System: before 17.8 — fixed in 17.8
How to fix
Upgrade to a fixed version: vanquish WooCommerce Support Ticket System 17.8. Check the vendor advisory for mitigations.
References
- https://codecanyon.net/item/woocommerce-support-ticket-system/17930050
- https://www.wordfence.com/threat-intel/vulnerabilities/id/1ac218f6-0bfa-480c-9159-d75a027022ba?source=cve
Get alerted when CVE-2024-10627 or the next vulnerability affects your stack