What’s Vulnerable › Vulnerabilities
CVE-2024-10628: Quiz Maker Business, Developer, and Agency <= (Multiple Versions) - Unauthenticated SQL Injection via id
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-01-26 · updated 2026-06-17
- Weakness: CWE-89
Description
The Quiz Maker Business, Developer, and Agency plugins for WordPress is vulnerable to SQL Injection via the ‘id’ parameter in all versions up to, and including, 8.8.0 (Business), up to, and including, 21.8.0 (Developer), and up to, and including, 31.8.0 (Agency) due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for unauthenticated attackers to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database. NOTE: The three variations of this software (Business, Developer, and Agency) share the same plugin slug, so you may get an alert even if you are running the latest version of any of the pieces of software. In these cases it is safe to dismiss the notice once you've confirmed your site is on a patched version of the applicable software.
Affected products
- Ays Pro Quiz Maker: from 7.0.0 before 8.8.0.100; from 20.0.0 before 21.8.0.100; from 30.0.0 before 31.8.0.100 — fixed in 21.8.0.100, 31.8.0.100, 8.8.0.100
How to fix
Upgrade to a fixed version: Ays Pro Quiz Maker 21.8.0.100, 31.8.0.100, 8.8.0.100. Check the vendor advisory for mitigations.
References
- https://abrahack.com/posts/quiz-maker-sqli/
- https://ays-pro.com/changelog-for-quiz-maker-pro
- https://ays-pro.com/wordpress/quiz-maker
- https://www.wordfence.com/threat-intel/vulnerabilities/id/9bd873e5-fd65-48c3-a71d-aaf6d8372606?source=cve
- https://abrahack.com/posts/quiz-maker-sqli/
Get alerted when CVE-2024-10628 or the next vulnerability affects your stack