What’s Vulnerable › Vulnerabilities
CVE-2024-10637: Kadence Blocks < 3.2.54 - Admin+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-12-12 · updated 2026-06-17
- Weakness: CWE-79
Description
The Gutenberg Blocks with AI by Kadence WP WordPress plugin before 3.2.54 does not validate and escape some of its block options before outputting them back in a page/post where the block is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks.
Affected products
- stellarwp Kadence Blocks — Page Builder Toolkit for Gutenberg Editor: before 3.2.54 — fixed in 3.2.54
How to fix
Upgrade to a fixed version: stellarwp Kadence Blocks — Page Builder Toolkit for Gutenberg Editor 3.2.54. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/df688dcc-9617-4f58-a310-891bfaea3695/
- https://wpscan.com/vulnerability/df688dcc-9617-4f58-a310-891bfaea3695/
Get alerted when CVE-2024-10637 or the next vulnerability affects your stack