What’s Vulnerable › Vulnerabilities
CVE-2024-10639: Auto Prune Posts < 3.0.0- Admin+ Stored XSS
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-05-15 · updated 2026-06-17
- Weakness: CWE-79
Description
The Auto Prune Posts WordPress plugin before 3.0.0 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
Affected products
- Auto Prune Posts: before 3.0.0 — fixed in 3.0.0
How to fix
Upgrade to a fixed version: Auto Prune Posts 3.0.0. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/efab3a36-535b-40ff-b98f-482a0e5193f1/
- https://wpscan.com/vulnerability/efab3a36-535b-40ff-b98f-482a0e5193f1/
Get alerted when CVE-2024-10639 or the next vulnerability affects your stack