What’s Vulnerable › Vulnerabilities
CVE-2024-10671: Button Block – Get fully customizable & multi-functional buttons <= 1.1.4 - Authenticated (Contributor+) Post Disclosure
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-21 · updated 2026-06-17
- Weakness: CWE-639
Description
The Button Block – Get fully customizable & multi-functional buttons plugin for WordPress is vulnerable to Information Exposure in all versions up to, and including, 1.1.4 via the [btn_block] shortcode due to insufficient restrictions on which posts can be included. This makes it possible for authenticated attackers, with Contributor-level access and above, to extract data from password protected, private, or draft posts that they should not have access to.
Affected products
- bPlugins Button Block: before 1.1.5 — fixed in 1.1.5
How to fix
Upgrade to a fixed version: bPlugins Button Block 1.1.5. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3188802/button-block/tags/1.1.5/inc/class-button-block-common.php?old=3176453&old_path=button-block%2Ftags%2F1.1.4%2Finc%2Fclass-button-block-common.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/99c7eead-2cf2-4663-9328-671274f3c436?source=cve
Get alerted when CVE-2024-10671 or the next vulnerability affects your stack