What’s Vulnerable › Vulnerabilities
CVE-2024-10678: Ultimate Blocks < 3.2.4 - Contributor+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-12-13 · updated 2026-06-17
- Weakness: CWE-79
Description
The Ultimate Blocks WordPress plugin before 3.2.4 does not validate and escape some of its block options before outputting them back in a page/post where the block is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks.
Affected products
- ultimateblocks Ultimate Blocks – 25+ Gutenberg Blocks for Block Editor: before 3.2.4 — fixed in 3.2.4
How to fix
Upgrade to a fixed version: ultimateblocks Ultimate Blocks – 25+ Gutenberg Blocks for Block Editor 3.2.4. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/9342c6a1-4f9a-45f3-911d-0dfee4657243/
- https://wpscan.com/vulnerability/9342c6a1-4f9a-45f3-911d-0dfee4657243/
Get alerted when CVE-2024-10678 or the next vulnerability affects your stack