What’s Vulnerable › Vulnerabilities
CVE-2024-10679: Quiz and Survey Master (QSM) < 9.2.1 - Author+ Stored XSS
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-03-25 · updated 2026-06-17
- Weakness: CWE-79
Description
The Quiz and Survey Master (QSM) WordPress plugin before 9.2.1 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
Affected products
- ExpressTech Quiz And Survey Master: before 9.2.1 — fixed in 9.2.1
How to fix
Upgrade to a fixed version: ExpressTech Quiz And Survey Master 9.2.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-10679 or the next vulnerability affects your stack