What’s Vulnerable › Vulnerabilities
CVE-2024-10684: Kognetiks Chatbot for WordPress <= 2.1.7 - Reflected Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-13 · updated 2026-06-17
- Weakness: CWE-79
Description
The Kognetiks Chatbot for WordPress plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the 'dir' parameter in all versions up to, and including, 2.1.7 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.
Affected products
- Kognetiks Chatbot for WordPress: before 2.1.8 — fixed in 2.1.8
How to fix
Upgrade to a fixed version: Kognetiks Chatbot for WordPress 2.1.8. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3183413/chatbot-chatgpt/trunk/includes/settings/chatbot-settings-support.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/d6fcd334-4d9a-4c11-ab11-b96cdda698c4?source=cve
Get alerted when CVE-2024-10684 or the next vulnerability affects your stack