What’s Vulnerable › Vulnerabilities
CVE-2024-1069: Contact Form Entries <= 1.3.2 - Authenticated (Administrator+) Arbitrary File Upload
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-01-31 · updated 2026-06-17
- Weakness: CWE-434
Description
The Contact Form Entries plugin for WordPress is vulnerable to arbitrary file uploads due to insufficient file validation on the 'view_page' function in versions up to, and including, 1.3.2. This makes it possible for authenticated attackers with administrator-level capabilities or above, to upload arbitrary files on the affected site's server which may make remote code execution possible.
Affected products
- crmperks Database for Contact Form 7, WPforms, Elementor forms: before 1.3.3 — fixed in 1.3.3
How to fix
Upgrade to a fixed version: crmperks Database for Contact Form 7, WPforms, Elementor forms 1.3.3. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/contact-form-entries/trunk/includes/plugin-pages.php?rev=3003884#L1213
- https://plugins.trac.wordpress.org/changeset/3028640/contact-form-entries#file1
- https://www.wordfence.com/threat-intel/vulnerabilities/id/120313be-9f98-4448-9f5d-a77186a6ff08?source=cve
- https://plugins.trac.wordpress.org/browser/contact-form-entries/trunk/includes/plugin-pages.php?rev=3003884#L1213
- https://plugins.trac.wordpress.org/changeset/3028640/contact-form-entries#file1
- https://www.wordfence.com/threat-intel/vulnerabilities/id/120313be-9f98-4448-9f5d-a77186a6ff08?source=cve
Get alerted when CVE-2024-1069 or the next vulnerability affects your stack