What’s Vulnerable › Vulnerabilities
CVE-2024-10693: SKT Addons for Elementor <= 3.3 - Authenticated (Contributor+) Post Disclosure
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-09 · updated 2026-06-17
- Weakness: CWE-639
Description
The SKT Addons for Elementor plugin for WordPress is vulnerable to Information Exposure in all versions up to, and including, 3.3 via the Unfold widget due to insufficient restrictions on which posts can be included. This makes it possible for authenticated attackers, with Contributor-level access and above, to extract data from private or draft posts created by Elementor that they should not have access to.
Affected products
- sonalsinha21 SKT Addons for Elementor: before 3.4 — fixed in 3.4
How to fix
Upgrade to a fixed version: sonalsinha21 SKT Addons for Elementor 3.4. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3183804%40skt-addons-for-elementor&new=3183804%40skt-addons-for-elementor&sfp_email=&sfph_mail=
- https://www.wordfence.com/threat-intel/vulnerabilities/id/8accf552-f235-46dd-857b-330eef7765a0?source=cve
Get alerted when CVE-2024-10693 or the next vulnerability affects your stack