What’s Vulnerable › Vulnerabilities
CVE-2024-10695: Futurio Extra <= 2.0.13 - Authenticated (Contributor+) Post Disclosure
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-12 · updated 2026-06-17
- Weakness: CWE-639
Description
The Futurio Extra plugin for WordPress is vulnerable to Information Exposure in all versions up to, and including, 2.0.13 via the 'elementor-template' shortcode due to insufficient restrictions on which posts can be included. This makes it possible for authenticated attackers, with Contributor-level access and above, to extract data from private or draft posts that they should not have access to.
Affected products
- FuturioWP Futurio Extra: before 2.0.14 — fixed in 2.0.14
How to fix
Upgrade to a fixed version: FuturioWP Futurio Extra 2.0.14. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3184380%40futurio-extra&new=3184380%40futurio-extra&sfp_email=&sfph_mail=#file3
- https://www.wordfence.com/threat-intel/vulnerabilities/id/53871750-6437-459f-97e1-5cf524160f09?source=cve
Get alerted when CVE-2024-10695 or the next vulnerability affects your stack