What’s Vulnerable › Vulnerabilities
CVE-2024-10703: Registrations for The Events Calendar < 2.13.4 - Admin+ Stored XSS
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-03-25 · updated 2026-06-17
- Weakness: CWE-79
Description
The Registrations for the Events Calendar WordPress plugin before 2.13.4 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
Affected products
- Registrations for the Events Calendar – Event Registration Plugin: before 2.13.4 — fixed in 2.13.4
How to fix
Upgrade to a fixed version: Registrations for the Events Calendar – Event Registration Plugin 2.13.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-10703 or the next vulnerability affects your stack