What’s Vulnerable › Vulnerabilities
CVE-2024-10705: Multiple Page Generator Plugin – MPG <= 4.0.5 - Authenticated (Editor+) Server-Side Request Forgery via fileUrl
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-26 · updated 2026-06-17
- Weakness: CWE-918
Description
The Multiple Page Generator Plugin – MPG plugin for WordPress is vulnerable to Server-Side Request Forgery in all versions up to, and including, 4.0.5 via the 'mpg_download_file_by_link' function. This makes it possible for authenticated attackers, with editor-level access and above, to make web requests to arbitrary locations originating from the web application and can be used to query and modify information from internal services.
Affected products
- themeisle Multiple Page Generator Plugin – MPG: before 4.0.6 — fixed in 4.0.6
How to fix
Upgrade to a fixed version: themeisle Multiple Page Generator Plugin – MPG 4.0.6. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3205550/multiple-pages-generator-by-porthas
- https://www.wordfence.com/threat-intel/vulnerabilities/id/7b3446e5-ca01-4468-927a-86e951e662ab?source=cve
Get alerted when CVE-2024-10705 or the next vulnerability affects your stack