What’s Vulnerable › Vulnerabilities
CVE-2024-10716
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-05 · updated 2026-06-17
- Weakness: CWE-79
Description
Pega Platform versions 8.1 to Infinity 24.2.0 are affected by an XSS issue with search.
Affected products
- Pega Systems Pega Infinity: from 8.1 through 8.8.5; from 23.1 before 23.1.4; from 24.1 before 24.1.2; 24.2 — fixed in 23.1.4, 24.1.2
How to fix
Upgrade to a fixed version: Pega Systems Pega Infinity 23.1.4, 24.1.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-10716 or the next vulnerability affects your stack