What’s Vulnerable › Vulnerabilities
CVE-2024-10718: Cookie without Secure attribute in phpipam/phpipam
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-03-20 · updated 2026-06-17
- Weakness: CWE-614
Description
In phpipam/phpipam version 1.5.1, the Secure attribute for sensitive cookies in HTTPS sessions is not set. This could cause the user agent to send those cookies in plaintext over an HTTP session, potentially exposing sensitive information. The issue is fixed in version 1.7.0.
Affected products
- phpipam/phpipam: before 1.7.0 — fixed in 1.7.0
How to fix
Upgrade to a fixed version: phpipam/phpipam 1.7.0. Check the vendor advisory for mitigations.
References
- https://github.com/phpipam/phpipam/commit/ddf70ef6801442eb8b0be5eea829e470e653c70e
- https://huntr.com/bounties/725bce8f-328f-4fbc-acf5-46ea920cd3c1
Get alerted when CVE-2024-10718 or the next vulnerability affects your stack