What’s Vulnerable › Vulnerabilities
CVE-2024-10719: Stored Cross-site Scripting (XSS) in phpipam/phpipam
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-03-20 · updated 2026-06-17
- Weakness: CWE-79
Description
A stored cross-site scripting (XSS) vulnerability exists in phpipam version 1.5.2, specifically in the circuits options functionality. This vulnerability allows an attacker to inject malicious scripts via the 'option' parameter in the POST request to /phpipam/app/admin/circuits/edit-options-submit.php. The injected script can be executed in the context of the user's browser, leading to potential cookie theft and end-user file disclosure. The issue is fixed in version 1.7.0.
Affected products
- phpipam/phpipam: before 1.7.0 — fixed in 1.7.0
How to fix
Upgrade to a fixed version: phpipam/phpipam 1.7.0. Check the vendor advisory for mitigations.
References
- https://github.com/phpipam/phpipam/commit/c1697bb6c4e4a6403d69c0868e1eb1040f98b731
- https://huntr.com/bounties/56aba8cb-4da1-44b4-8c4d-c5ba00ea3670
Get alerted when CVE-2024-10719 or the next vulnerability affects your stack