What’s Vulnerable › Vulnerabilities
CVE-2024-10722: Stored Cross-site Scripting (XSS) in phpipam/phpipam
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-03-20 · updated 2026-06-17
- Weakness: CWE-79
Description
A stored cross-site scripting (XSS) vulnerability exists in phpipam/phpipam version 1.5.2. The vulnerability allows attackers to inject malicious scripts into the 'Description' field of custom fields in the 'IP RELATED MANAGEMENT' section. This can lead to data theft, account compromise, distribution of malware, website defacement, content manipulation, and phishing attacks. The issue is fixed in version 1.7.0.
Affected products
- phpipam/phpipam: before 1.7.0 — fixed in 1.7.0
How to fix
Upgrade to a fixed version: phpipam/phpipam 1.7.0. Check the vendor advisory for mitigations.
References
- https://github.com/phpipam/phpipam/commit/c1697bb6c4e4a6403d69c0868e1eb1040f98b731
- https://huntr.com/bounties/f0bc97b2-33a9-4b15-aa05-ff7c57624847
Get alerted when CVE-2024-10722 or the next vulnerability affects your stack