What’s Vulnerable › Vulnerabilities
CVE-2024-10725: Stored Cross-site Scripting (XSS) in phpipam/phpipam
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-03-20 · updated 2026-06-17
- Weakness: CWE-79
Description
A stored cross-site scripting (XSS) vulnerability exists in phpipam/phpipam version 1.5.2. This vulnerability allows an attacker to inject malicious scripts into the application, which are then executed in the context of other users who view the affected pages. The issue occurs when editing the NAT destination address, where user input is not properly sanitized. This can lead to data theft, account compromise, and other malicious activities. The vulnerability is fixed in version 1.7.0.
Affected products
- phpipam/phpipam: before 1.7.0 — fixed in 1.7.0
How to fix
Upgrade to a fixed version: phpipam/phpipam 1.7.0. Check the vendor advisory for mitigations.
References
- https://github.com/phpipam/phpipam/commit/c1697bb6c4e4a6403d69c0868e1eb1040f98b731
- https://huntr.com/bounties/343465fa-6dec-40af-a012-7b118e91a771
Get alerted when CVE-2024-10725 or the next vulnerability affects your stack