What’s Vulnerable › Vulnerabilities
CVE-2024-10728: PostX <= 4.1.16 - Missing Authorization to Arbitrary Plugin Installation/Activation
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 39.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-16 · updated 2026-06-17
- Weakness: CWE-862
Description
The Post Grid Gutenberg Blocks and WordPress Blog Plugin – PostX plugin for WordPress is vulnerable to unauthorized plugin installation/activation due to a missing capability check on the 'install_required_plugin_callback' function in all versions up to, and including, 4.1.16. This makes it possible for authenticated attackers, with Subscriber-level access and above, to install and activate arbitrary plugins which can be leveraged to achieve remote code execution if another vulnerable plugin is installed and activated.
Affected products
- WPXPO PostX: before 4.1.17 — fixed in 4.1.17
How to fix
Upgrade to a fixed version: WPXPO PostX 4.1.17. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/ultimate-post/tags/4.1.16/classes/Importer.php#L94
- https://plugins.trac.wordpress.org/browser/ultimate-post/tags/4.1.16/classes/Initialization.php#L330
- https://plugins.trac.wordpress.org/changeset/3188636/ultimate-post/trunk/classes/Importer.php
- https://wordpress.org/plugins/ultimate-post/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/076f36fb-c2fb-43e0-a027-1351d3995489?source=cve
Get alerted when CVE-2024-10728 or the next vulnerability affects your stack