What’s Vulnerable › Vulnerabilities
CVE-2024-10762: Missing Authorization in lunary-ai/lunary
- Severity: high (CVSS 8.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-03-20 · updated 2026-06-17
- Weakness: CWE-862
Description
In lunary-ai/lunary before version 1.5.9, the /v1/evaluators/ endpoint allows users to delete evaluators of a project by sending a DELETE request. However, the route lacks proper access control, such as middleware to ensure that only users with appropriate roles can delete evaluator data. This vulnerability allows low-privilege users to delete evaluators data, causing permanent data loss and potentially hindering operations.
Affected products
- lunary-ai/lunary: before 1.5.9 — fixed in 1.5.9
How to fix
Upgrade to a fixed version: lunary-ai/lunary 1.5.9. Check the vendor advisory for mitigations.
References
- https://github.com/lunary-ai/lunary/commit/91587496673da24cb7ddedfbbd6e602592b20ef6
- https://huntr.com/bounties/23ab508e-d956-4861-b28f-0569d3b404a6
Get alerted when CVE-2024-10762 or the next vulnerability affects your stack