What’s Vulnerable › Vulnerabilities
CVE-2024-10770: Envo Extra <= 1.9.3 - Authenticated (Contributor+) Post Disclosure
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-09 · updated 2026-06-17
- Weakness: CWE-639
Description
The Envo Extra plugin for WordPress is vulnerable to Information Exposure in all versions up to, and including, 1.9.3 via the 'elementor-template' shortcode due to insufficient restrictions on which posts can be included. This makes it possible for authenticated attackers, with Contributor-level access and above, to extract data from private or draft posts created by Elementor that they should not have access to.
Affected products
- EnvoThemes Envo Extra: before 1.9.4 — fixed in 1.9.4
How to fix
Upgrade to a fixed version: EnvoThemes Envo Extra 1.9.4. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3182181%40envo-extra&new=3182181%40envo-extra&sfp_email=&sfph_mail=
- https://www.wordfence.com/threat-intel/vulnerabilities/id/08b0f5e0-f68a-4fea-9d62-468956012a6d?source=cve
Get alerted when CVE-2024-10770 or the next vulnerability affects your stack