What’s Vulnerable › Vulnerabilities
CVE-2024-10778: BuddyPress Builder for Elementor – BuddyBuilder <= 1.7.4 - Authenticated (Contributor+) Post Disclosure
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-13 · updated 2026-06-17
- Weakness: CWE-639
Description
The BuddyPress Builder for Elementor – BuddyBuilder plugin for WordPress is vulnerable to Information Exposure in all versions up to, and including, 1.7.4 via the 'elementor-template' shortcode due to insufficient restrictions on which posts can be included. This makes it possible for authenticated attackers, with Contributor-level access and above, to extract data from private or draft posts crated by Elementor that they should not have access to.
Affected products
- staxwp BuddyPress Builder for Elementor – BuddyBuilder: before 1.8.0 — fixed in 1.8.0
How to fix
Upgrade to a fixed version: staxwp BuddyPress Builder for Elementor – BuddyBuilder 1.8.0. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&new=3187364%40stax-buddy-builder%2Ftrunk&old=2935606%40stax-buddy-builder%2Ftrunk&sfp_email=&sfph_mail=
- https://wordpress.org/plugins/stax-buddy-builder/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/067dde3a-f2d6-44c6-b64e-c8a850dd4d37?source=cve
Get alerted when CVE-2024-10778 or the next vulnerability affects your stack