What’s Vulnerable › Vulnerabilities
CVE-2024-10780: Restaurant & Cafe Addon for Elementor <= 1.5.9 - Authenticated (Contributor+) Post Disclosure
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-28 · updated 2026-06-17
- Weakness: CWE-639
Description
The Restaurant & Cafe Addon for Elementor plugin for WordPress is vulnerable to Information Exposure in all versions up to, and including, 1.5.9 via the 'narestaurant_elementor_template' shortcode due to insufficient restrictions on which posts can be included. This makes it possible for authenticated attackers, with Contributor-level access and above, to extract data from private or draft posts created by Elementor that they should not have access to.
Affected products
- nicheaddons Restaurant & Cafe Addon for Elementor: before 1.6.0 — fixed in 1.6.0
How to fix
Upgrade to a fixed version: nicheaddons Restaurant & Cafe Addon for Elementor 1.6.0. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3197286%40restaurant-cafe-addon-for-elementor&new=3197286%40restaurant-cafe-addon-for-elementor&sfp_email=&sfph_mail=
- https://www.wordfence.com/threat-intel/vulnerabilities/id/a8c29cbd-6c39-4a54-a2a2-bc4c8feeeb70?source=cve
Get alerted when CVE-2024-10780 or the next vulnerability affects your stack