What’s Vulnerable › Vulnerabilities
CVE-2024-10800: WordPress User Extra Fields <= 16.6 - Missing Authorization to Authenticated (Subscriber+) Privilege Escalation
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-13 · updated 2026-06-17
- Weakness: CWE-862
Description
The WordPress User Extra Fields plugin for WordPress is vulnerable to privilege escalation due to a missing capability check on the ajax_save_fields() function in all versions up to, and including, 16.6. This makes it possible for authenticated attackers, with subscriber-level access and above, to add custom fields that can be updated and then use the check_and_overwrite_wp_or_woocommerce_fields function to update the wp_capabilities field to have administrator privileges.
Affected products
- vanquish WordPress User Extra Fields: before 16.7 — fixed in 16.7
How to fix
Upgrade to a fixed version: vanquish WordPress User Extra Fields 16.7. Check the vendor advisory for mitigations.
References
- https://codecanyon.net/item/user-extra-fields/12949844
- https://www.wordfence.com/threat-intel/vulnerabilities/id/a18fa7e6-813d-4b48-bd4e-5232fb8382d1?source=cve
Get alerted when CVE-2024-10800 or the next vulnerability affects your stack