What’s Vulnerable › Vulnerabilities
CVE-2024-10813: Product Table for WooCommerce by CodeAstrology (wooproducttable.com) <= 3.5.1 - Information Exposure
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-23 · updated 2026-06-17
- Weakness: CWE-862
Description
The Product Table for WooCommerce by CodeAstrology (wooproducttable.com) plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 3.5.1 via the var_dump_table parameter. This makes it possible for unauthenticated attackers var data.
Affected products
- codersaiful Product Table for WooCommerce: before 3.5.2 — fixed in 3.5.2
How to fix
Upgrade to a fixed version: codersaiful Product Table for WooCommerce 3.5.2. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/woo-product-table/trunk/inc/shortcode-base.php
- https://plugins.trac.wordpress.org/changeset/3195719/woo-product-table/trunk/inc/shortcode-base.php?contextall=1
- https://www.wordfence.com/threat-intel/vulnerabilities/id/e67f680a-8942-45fa-8458-a27c78045aa1?source=cve
Get alerted when CVE-2024-10813 or the next vulnerability affects your stack