What’s Vulnerable › Vulnerabilities
CVE-2024-10818: JSFiddle Shortcode < 1.1.3 - Contributor+ XSS via Shortcode
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-05-15 · updated 2026-06-17
- Weakness: CWE-79
Description
The JSFiddle Shortcode WordPress plugin before 1.1.3 does not validate and escape some of its shortcode attributes before outputting them back in a page/post where the shortcode is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks.
Affected products
- JSFiddle Shortcode: before 1.1.3 — fixed in 1.1.3
How to fix
Upgrade to a fixed version: JSFiddle Shortcode 1.1.3. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/aafd152c-1a05-4191-a1bc-b802d801ca03/
- https://wpscan.com/vulnerability/aafd152c-1a05-4191-a1bc-b802d801ca03/
Get alerted when CVE-2024-10818 or the next vulnerability affects your stack