What’s Vulnerable › Vulnerabilities
CVE-2024-1084
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-02-13 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site Scripting in the tag name pattern field in the tag protections UI in GitHub Enterprise Server allows a malicious website that requires user interaction and social engineering to make changes to a user account via CSP bypass with created CSRF tokens. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.12 and was fixed in all versions of 3.11.5, 3.10.7, 3.9.10, and 3.8.15. This vulnerability was reported via the GitHub Bug Bounty program.
Affected products
- GitHub Enterprise Server: before 3.8.15; from 3.9.0 before 3.9.10; from 3.10.0 before 3.10.7; from 3.11.0 before 3.11.5 — fixed in 3.10.7, 3.11.5, 3.8.15, 3.9.10
How to fix
Upgrade to a fixed version: GitHub Enterprise Server 3.10.7, 3.11.5, 3.8.15, 3.9.10. Check the vendor advisory for mitigations.
References
- https://docs.github.com/en/enterprise-server@3.10/admin/release-notes#3.10.7
- https://docs.github.com/en/enterprise-server@3.11/admin/release-notes#3.11.5
- https://docs.github.com/en/enterprise-server@3.8/admin/release-notes#3.8.15
- https://docs.github.com/en/enterprise-server@3.9/admin/release-notes#3.9.10
- https://docs.github.com/en/enterprise-server@3.10/admin/release-notes#3.10.7
- https://docs.github.com/en/enterprise-server@3.11/admin/release-notes#3.11.5
- https://docs.github.com/en/enterprise-server@3.8/admin/release-notes#3.8.15
- https://docs.github.com/en/enterprise-server@3.9/admin/release-notes#3.9.10
Get alerted when CVE-2024-1084 or the next vulnerability affects your stack