What’s Vulnerable › Vulnerabilities
CVE-2024-10850: Razorpay Payment Button for Elementor <= 1.2.5 - Reflected Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-13 · updated 2026-06-17
- Weakness: CWE-79
Description
The Razorpay Payment Button Elementor Plugin plugin for WordPress is vulnerable to Reflected Cross-Site Scripting due to the use of add_query_arg & remove_query_arg without appropriate escaping on the URL in all versions up to, and including, 1.2.5. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.
Affected products
- Razorpay Payment Button: before 1.2.6 — fixed in 1.2.6
How to fix
Upgrade to a fixed version: Razorpay Payment Button 1.2.6. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/razorpay-payment-button-elementor/tags/1.2.5/includes/rzp-payment-buttons.php#L78
- https://plugins.trac.wordpress.org/changeset/3186535/razorpay-payment-button-elementor/trunk/includes/rzp-payment-buttons.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/9331aa66-2eee-4745-b286-fa6db3bd9f37?source=cve
Get alerted when CVE-2024-10850 or the next vulnerability affects your stack