What’s Vulnerable › Vulnerabilities
CVE-2024-10856: Booking Calendar WpDevArt <= 3.2.19 - Authenticated (Contributor+) SQL Injection
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-24 · updated 2026-06-17
- Weakness: CWE-89
Description
The Booking Calendar WpDevArt plugin is vulnerable to time-based, blind SQL injection via the `id` parameter in the “wpdevart_booking_calendar” shortcode in versions up to, and including, 3.2.19 due to insufficient escaping on the user-supplied parameter and lack of sufficient preparation on the existing SQL query. The vulnerability requires the “delete_prev_date” theme option being enabled. This makes it possible for authenticated attackers, with contributor-level access or above, to append additional SQL queries into already existing query that can be used to extract sensitive information such as passwords from the database.
Affected products
- wpdevart Booking calendar, Appointment Booking System: before 3.2.0 — fixed in 3.2.0
How to fix
Upgrade to a fixed version: wpdevart Booking calendar, Appointment Booking System 3.2.0. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/booking-calendar/tags/3.2.15/includes/main_class.php#L90
- https://plugins.trac.wordpress.org/browser/booking-calendar/tags/3.2.15/includes/main_class.php#L91
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3209851%40booking-calendar&new=3209851%40booking-calendar&sfp_email=&sfph_mail=
- https://www.wordfence.com/threat-intel/vulnerabilities/id/bf297cd8-3d67-4750-b856-38ded4daf4ad?source=cve
Get alerted when CVE-2024-10856 or the next vulnerability affects your stack