What’s Vulnerable › Vulnerabilities
CVE-2024-10857: Product Input Fields for WooCommerce <= 1.9 - Authenticated (Contributor+) Arbitrary File Read
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-26 · updated 2026-06-17
- Weakness: CWE-35
Description
The Product Input Fields for WooCommerce plugin for WordPress is vulnerable to Directory Traversal in all versions up to, and including, 1.9 via the handle_downloads() function due to insufficient file path validation/sanitization. This makes it possible for authenticated attackers, with Contributor-level access and above, to read the contents of arbitrary files on the server, which can contain sensitive information.
Affected products
- tychesoftwares Product Input Fields for WooCommerce: before 2.0 — fixed in 2.0
How to fix
Upgrade to a fixed version: tychesoftwares Product Input Fields for WooCommerce 2.0. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3195423/product-input-fields-for-woocommerce/trunk?contextall=1&old=3173573&old_path=%2Fproduct-input-fields-for-woocommerce%2Ftrunk
- https://www.wordfence.com/threat-intel/vulnerabilities/id/e45207af-3886-4d95-9cd8-5ecdc683dc58?source=cve
Get alerted when CVE-2024-10857 or the next vulnerability affects your stack