What’s Vulnerable › Vulnerabilities

CVE-2024-10858: Jetpack 13.0-14.0 - Unauthenticated DOM-XSS

Description

The Jetpack WordPress plugin before 14.1 does not properly checks the postmessage origin in its 13.x versions, allowing it to be bypassed and leading to DOM-XSS. The issue only affects websites hosted on WordPress.com.

Affected products

How to fix

Upgrade to a fixed version: Jetpack 14.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-10858 or the next vulnerability affects your stack