What’s Vulnerable › Vulnerabilities
CVE-2024-1088: Password Protected Store for WooCommerce <= 2.2 - Information Exposure via REST API
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-05 · updated 2026-06-17
- Weakness: CWE-284
Description
The Password Protected Store for WooCommerce plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 2.2 via the REST API. This makes it possible for unauthenticated attackers to extract sensitive data including post titles and content.
Affected products
- rajkakadiya Password Protected Store for WooCommerce: before 2.3 — fixed in 2.3
How to fix
Upgrade to a fixed version: rajkakadiya Password Protected Store for WooCommerce 2.3. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3046244%40password-protected-woo-store&new=3046244%40password-protected-woo-store&sfp_email=&sfph_mail=
- https://wordpress.org/plugins/password-protected-woo-store/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/7ae1e8fd-4d1b-4590-a141-f93d6347c0f2?source=cve
- https://wordpress.org/plugins/password-protected-woo-store/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/7ae1e8fd-4d1b-4590-a141-f93d6347c0f2?source=cve
Get alerted when CVE-2024-1088 or the next vulnerability affects your stack