What’s Vulnerable › Vulnerabilities
CVE-2024-10885: SearchIQ – The Search Solution <= 4.6 - Authenticated (Contributor+) Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-04 · updated 2026-06-17
- Weakness: CWE-79
Description
The SearchIQ – The Search Solution plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'siq_searchbox' shortcode in all versions up to, and including, 4.6 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- SearchIQ: before 4.7 — fixed in 4.7
How to fix
Upgrade to a fixed version: SearchIQ 4.7. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/searchiq/tags/4.6/library/shortcode.php#L66
- https://plugins.trac.wordpress.org/changeset/3198694/searchiq/trunk/library/shortcode.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/86e8e16f-9d93-457a-9093-2fd236e51682?source=cve
Get alerted when CVE-2024-10885 or the next vulnerability affects your stack