What’s Vulnerable › Vulnerabilities
CVE-2024-10891: Save as PDF Plugin by Pdfcrowd <= 4.2.1 - Authenticated (Contributor+) Stored Cross-Site Scripting
- Severity: medium (CVSS 6.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-20 · updated 2026-06-17
- Weakness: CWE-79
Description
The Save as PDF Plugin by Pdfcrowd plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'save_as_pdf_pdfcrowd' shortcode in all versions up to, and including, 4.2.1 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- Pdfcrowd Save as PDF plugin by Pdfcrowd: before 4.2.2 — fixed in 4.2.2
How to fix
Upgrade to a fixed version: Pdfcrowd Save as PDF plugin by Pdfcrowd 4.2.2. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/save-as-pdf-by-pdfcrowd/trunk/public/class-save-as-pdf-pdfcrowd-public.php#L586
- https://www.wordfence.com/threat-intel/vulnerabilities/id/3763d893-83a0-4b6a-9c21-34a69313d555?source=cve
Get alerted when CVE-2024-10891 or the next vulnerability affects your stack