What’s Vulnerable › Vulnerabilities
CVE-2024-10893: WP Booking Calendar < 10.6.5 - Admin+ Stored XSS
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-12-03 · updated 2026-06-17
- Weakness: CWE-79
Description
The WP Booking Calendar WordPress plugin before 10.6.5 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
Affected products
- wpdevelop Booking Calendar: before 10.6.5 — fixed in 10.6.5
How to fix
Upgrade to a fixed version: wpdevelop Booking Calendar 10.6.5. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-10893 or the next vulnerability affects your stack