What’s Vulnerable › Vulnerabilities
CVE-2024-10903: Broken Link Checker < 2.4.2 - Admin+ SSRF
- Severity: medium (CVSS 4.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-12-26 · updated 2026-06-17
- Weakness: CWE-918
Description
The Broken Link Checker WordPress plugin before 2.4.2 does not validate a the link URLs before making a request to them, which could allow admin users to perform SSRF attack, for example on a multisite installation.
Affected products
- wpmudev Broken Link Checker: before 2.4.2 — fixed in 2.4.2
How to fix
Upgrade to a fixed version: wpmudev Broken Link Checker 2.4.2. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/39027390-ce01-4dd5-a979-426785aa7acb/
- https://wpscan.com/vulnerability/39027390-ce01-4dd5-a979-426785aa7acb/
Get alerted when CVE-2024-10903 or the next vulnerability affects your stack