What’s Vulnerable › Vulnerabilities
CVE-2024-10921: Improper neutralization of null bytes may lead to buffer over-reads in MongoDB Server
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-14 · updated 2026-06-17
- Weakness: CWE-158
Description
An authorized user may trigger crashes or receive the contents of buffer over-reads of Server memory by issuing specially crafted requests that construct malformed BSON in the MongoDB Server. This issue affects MongoDB Server v5.0 versions prior to 5.0.30 , MongoDB Server v6.0 versions prior to 6.0.19, MongoDB Server v7.0 versions prior to 7.0.15 and MongoDB Server v8.0 versions prior to and including 8.0.2.
Affected products
- MongoDB: from 5.0.0 before 5.0.30; from 6.0.0 before 6.0.19; from 7.0.0 before 7.0.15; from 8.0.0 before 8.0.3 — fixed in 5.0.30, 6.0.19, 7.0.15, 8.0.3
How to fix
Upgrade to a fixed version: MongoDB 5.0.30, 6.0.19, 7.0.15, 8.0.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-10921 or the next vulnerability affects your stack