What’s Vulnerable › Vulnerabilities
CVE-2024-10939: Image Widget < 4.4.11 - Admin+ Stored XSS
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-12-13 · updated 2026-06-17
- Weakness: CWE-79
Description
The Image Widget WordPress plugin before 4.4.11 does not sanitise and escape some of its Image Widget settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
Affected products
- StellarWP Image Widget: before 4.4.11 — fixed in 4.4.11
How to fix
Upgrade to a fixed version: StellarWP Image Widget 4.4.11. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/fcf50077-b360-4b63-bece-9806b4bc8bea/
- https://wpscan.com/vulnerability/fcf50077-b360-4b63-bece-9806b4bc8bea/
Get alerted when CVE-2024-10939 or the next vulnerability affects your stack