What’s Vulnerable › Vulnerabilities
CVE-2024-10958: WP Photo Album Plus <= 8.8.08.007 - Unauthenticated Arbitrary Shortcode Execution via getshortcodedrenderedfenodelay
- Severity: high (CVSS 7.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-10 · updated 2026-06-17
- Weakness: CWE-94
Description
The The WP Photo Album Plus plugin for WordPress is vulnerable to arbitrary shortcode execution via getshortcodedrenderedfenodelay AJAX action in all versions up to, and including, 8.8.08.007 . This is due to the software allowing users to execute an action that does not properly validate a value before running do_shortcode. This makes it possible for unauthenticated attackers to execute arbitrary shortcodes.
Affected products
- opajaap WP Photo Album Plus: before 8.9.01.001 — fixed in 8.9.01.001
How to fix
Upgrade to a fixed version: opajaap WP Photo Album Plus 8.9.01.001. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/wp-photo-album-plus/tags/8.8.08.004/wppa-ajax.php#L1238
- https://plugins.trac.wordpress.org/changeset/3184852/
- https://wordpress.org/plugins/wp-photo-album-plus/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/53bb0871-343a-4299-9902-682c422152d1?source=cve
Get alerted when CVE-2024-10958 or the next vulnerability affects your stack