What’s Vulnerable › Vulnerabilities
CVE-2024-10975: Nomad Vulnerable To Cross-Namespace Volume Creation Abusing CSI Write Permission
- Severity: high (CVSS 7.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-07 · updated 2026-06-17
- Weakness: CWE-863
Description
Nomad Community and Nomad Enterprise ("Nomad") volume specification is vulnerable to arbitrary cross-namespace volume creation through unauthorized Container Storage Interface (CSI) volume writes. This vulnerability, identified as CVE-2024-10975, is fixed in Nomad Community Edition 1.9.2 and Nomad Enterprise 1.9.2, 1.8.7, and 1.7.15.
Affected products
- HashiCorp Nomad Enterprise: from 1.3.0 before 1.7.15; from 1.3.0 before 1.9.2; from 1.8.0 before 1.8.7; from 1.9.0 before 1.9.2 — fixed in 1.7.15, 1.8.7, 1.9.2
How to fix
Upgrade to a fixed version: HashiCorp Nomad Enterprise 1.7.15, 1.8.7, 1.9.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-10975 or the next vulnerability affects your stack